Главная Макинтош Регистрация

Вход

Приветствую Вас Гость | RSSСуббота, 18.11.2017, 22:29
Наш опрос
Оцените мой сайт
Всего ответов: 3

Статистика

Онлайн всего: 1
Гостей: 1
Пользователей: 0

Форма входа


Главная » 2013 » Октябрь » 8 » [JIT-]компилятор для ruby 1.9.x
11:30
[JIT-]компилятор для ruby 1.9.x
Ruby 1.9.2 в разы быстрее 1.8.7 [1], однако при этом по прежнему проигрывает Python [2], особенно если Python c JIT-компилятором (например psyco или PyPy [3]).

Видно, что наличие компилятора сильно влияет на скорость исполнения программы, и, как следствие, на выбор использования/не использования языка в проектах. Испытывая некую симпатию к наркоманскому синтаксису ruby, я попытался такой компилятор найти. Мне нашлись rubyscript2exe (не совместим с 1.9), ludicrous (сайт не открывается) и ещё какой-то, годящийся только для windows (не подходит, потому что продакшн линуксовый).

Кто какие компиляторы знает и у кого есть опыт их использования?
Вас интересует аттестат? купить аттестат
Просмотров: 4510 | Добавил: admin | Рейтинг: 0.0/0
Всего комментариев: 0
Имя *:
Email *:
Код *:
Поиск

Календарь
«  Октябрь 2013  »
ПнВтСрЧтПтСбВс
 123456
78910111213
14151617181920
21222324252627
28293031

Архив записей

Copyright MyCorp © 2017Хостинг от uCoz